Cluster B - Inbound Delays
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Dec 31, 2019 - 15:40 UTC
Investigating
We are currently experiencing inbound mail delays on Cluster B. Our operations team is investigating the issue.

We will provide an update once we have additional information.
Posted Dec 31, 2019 - 15:14 UTC
This incident affected: Hosted Email (Cluster B).