Payment Failures

Incident Report for OpenSRS

Resolved

This incident has been resolved. Payments are now processing.

Start Time: 07/29/2024 18:53 UTC
End Time: 07/29/2024 21:00 UTC
Posted Jul 29, 2024 - 22:04 UTC

Monitoring

A fix has been applied and we are currently monitoring the results.
Posted Jul 29, 2024 - 21:32 UTC

Investigating

We are aware of current payment failures occurring when attempting to add funds to your account. Our engineers are investigating and further updates will be provided.
Posted Jul 29, 2024 - 20:18 UTC
This incident affected: Control Panels (Payment Gateway).