.ES Registry Connections

Incident Report for OpenSRS

Resolved

The .ES registry maintenance window has ended. All connection issues on our side have been resolved, and services are operating normally.
Posted Sep 26, 2026 - 17:24 UTC

Investigating

We are investigating connection issues with the .ES registry. Our engineering team is investigating and will update as soon as we hear back from the registry.

This affects registrations, renewals, and management of .ES domains. Existing domains will continue to resolve normally.
Posted Sep 26, 2026 - 14:45 UTC
This incident affected: Domain Services (Other ccTLDs).