Cluster B - Webmail Login
Incident Report for OpenSRS
Resolved
Our Engineering team has implemented a fix and the webmail services are now online.
Posted Mar 29, 2023 - 15:56 UTC
Investigating
We are investigating an issue preventing some users on Cluster B from logging into Webmail. Customers might notice login failures and database errors when accessing webmail. Our engineering team has been engaged.

We will provide an update once we have additional information.
Posted Mar 29, 2023 - 15:16 UTC
This incident affected: Hosted Email (Cluster B).