.MUSEUM Registry Connections
Incident Report for OpenSRS
Resolved
The registry has an ongoing incident at their end that they are working to resolve. However we are no longer seeing any connection issues with the .museum TLD, so we are marking this incident as resolved.

Incident Start Time: 05-30-2023 21:35:00 UTC
Incident End Time: 05-31-2023 18:56:00
Total Duration: 21 hours 49 minutes
Posted May 31, 2023 - 20:21 UTC
Update
We are still working on this and will update again when there is more progress.
Posted May 31, 2023 - 01:04 UTC
Update
Our team continues to work on the issue.
Posted May 31, 2023 - 00:04 UTC
Update
We are continuing to investigate the issue.
Posted May 30, 2023 - 23:02 UTC
Investigating
We are currently experiencing connection issues with the .museum registry. Our engineering team is investigating the issue.

This affects registrations, renewals, and management of .museum domains. Existing domains will continue to resolve normally.
Posted May 30, 2023 - 22:03 UTC
This incident affected: Domain Services (Other gTLDs).