SSL Geotrust QuickSSL Premium & Wildcard
Incident Report for OpenSRS
Resolved
This issue has been resolved by the vendor as our support team is no longer experiencing problems with purchases.

Incident Start Time: 12-10-2020 21:08:00
Incident End Time:12-11-2020 00:10:00
Total Duration:~ 3 hours
Posted Dec 11, 2020 - 00:40 UTC
Update
The issue has been identified by Digicert and a fix is being implemented. Updates will be provided as soon as possible
Posted Dec 10, 2020 - 23:53 UTC
Identified
Digicert has acknowledged an issue from their end.
Please see https://status.digicert.com/ for more information.

We will periodically provide updates as they come.
Posted Dec 10, 2020 - 22:39 UTC
Investigating
We are currently aware of an issue with purchasing Geotrust QuickSSL Premium & Wildcard products. Our engineering teams are investigating and we are opening a request with Digicert directly to investigate.
Posted Dec 10, 2020 - 22:10 UTC
This incident affected: SSL.