.EU maintenance: Extended period
Incident Report for OpenSRS
Resolved
This extended maintenance has now completed, and all .EU domain management has resumed.

Thanks for your patience.
Posted Dec 04, 2019 - 10:27 UTC
Identified
There is an unplanned extension to the scheduled maintenance at the .EU registry. Until completed, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart
Posted Dec 04, 2019 - 08:23 UTC
This incident affected: Domain Services (Other gTLDs).