Cluster B email delays
Incident Report for OpenSRS
Resolved
This issue is now resolved.
Posted 4 months ago. Jun 26, 2019 - 19:52 UTC
Monitoring
Our team has identified and implemented a solution to this issue.
Users should no longer experience email delay's on cluster B.

We will continue to monitor this issue.
Posted 4 months ago. Jun 26, 2019 - 19:26 UTC
Investigating
We are currently investigating an issue with one of our email clusters .
Users on cluster B may experience delays during this time.

We will keep our clients informed on this matter as new updates become available.
Posted 4 months ago. Jun 26, 2019 - 18:35 UTC
This incident affected: Hosted Email (Cluster B).