Cluster A Login Issue
Incident Report for OpenSRS
Resolved
All mail queues have cleared and all mail is now functional without any delays. The root cause is still under investigation and more details will be provided in the incident report.

Incident Start Time: 02-25-2022 16:37:00 UTC
Incident End Time: 02-26-2022 00:15:00 UTC
Total Duration:7 hours and 38 minutes
Posted Feb 26, 2022 - 01:07 UTC
Update
Our mail queues are now processing the backlog. This is being monitored closely and we will provide further updates as they become available.
Posted Feb 25, 2022 - 23:26 UTC
Update
Customers across A cluster are experiencing intermittent access issues due to DDoS/abuse that impacted our load balancer. Our engineering team is still working to resolve this issue. We will provide further updates as they become available.
Posted Feb 25, 2022 - 20:24 UTC
Identified
Our engineers report that there is now mail flow, however, there are still issues being worked on. We will provide updates as they become available.
Posted Feb 25, 2022 - 17:40 UTC
Investigating
We are experiencing degradation of service on cluster A. Some customers are unable to access their mailboxes at this time.
Posted Feb 25, 2022 - 17:09 UTC
This incident affected: Hosted Email (Cluster A).