.LONDON Registry Connection
Incident Report for OpenSRS
Resolved
We have been informed the registry is currently undergoing maintenance and services will be unavailable during this period. We will be updating a separate maintenance notice momentarily with the expected time of impact.
Posted Aug 31, 2021 - 13:50 UTC
Update
We have reached out to the registry to inquire further. We are still waiting on a response but we will provide updates as they become available.
Posted Aug 31, 2021 - 13:09 UTC
Update
We are currently experiencing connection issues with the .LONDON registry. Our engineering team is investigating the issue.

This affects registrations, renewals, and management of .LONDON domains. Existing domains will continue to resolve normally.
Posted Aug 31, 2021 - 11:44 UTC
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted Aug 31, 2021 - 11:41 UTC
This incident affected: Domain Services (Other ccTLDs).