Phone Support - Upstream Provider Outage
Incident Report for OpenSRS
Resolved
We have received word that our upstream provider has restored service, this incident is considered resolved.

Start: 22:27 UTC
End: 23:49 UTC
Posted Jan 13, 2021 - 23:49 UTC
Investigating
Due to an issue with one of our upstream providers we are experiencing issues with receiving calls, please use alternative means of contacting support by reaching out through our chat widget on opensrs.com or emailing help@opensrs.com for assistance.
Posted Jan 13, 2021 - 22:27 UTC