.TRAVEL Registry Connections
Incident Report for OpenSRS
Resolved
Our engineering teams have completed the registry backend migrations and this TLD is now fully serviceable again.

We are marking this incident resolved.

Start time: 2021-05-04
End time: 2021-05-27
Length: 23 days
Posted May 27, 2021 - 16:04 UTC
Investigating
We are currently experiencing connection issues with the .TRAVEL registry. Our engineering team is investigating the issue.

This affects registrations, renewals, and management of .TRAVEL domains. Existing domains will continue to resolve normally.
Posted May 04, 2021 - 12:52 UTC
This incident affected: Domain Services (Other gTLDs).