GeoTrust API Connection
Incident Report for OpenSRS
Resolved
Digicert has confirmed that a fix is now in place. We are no longer experiencing any issues and are considering the issue resolved.

Incident Start Time: 08-30-2020 12:15:00 UTC
Incident End Time: 08-30-2020 15:50:00 UTC
Total Duration: 3 hours and 35 minutes
Posted Aug 30, 2020 - 16:10 UTC
Monitoring
Our GeoTrust connections are back up currently, however, Digicert and their provider are still working on resolving their issue. We will continue to monitor the situation.
Posted Aug 30, 2020 - 15:34 UTC
Update
There is currently an outage reported by Digicert acknowledging "connectivity to digicert services unreachable from some countries". This is the likely cause of our connection failures. We are still awaiting confirmation.
Posted Aug 30, 2020 - 14:11 UTC
Update
We are continuing to investigate this issue.
Posted Aug 30, 2020 - 13:02 UTC
Investigating
Our connections to GeoTrust API are down currently, we have engaged the vendor to inquire. Customers will be unable to manage/configure GeoTrust SSL certificates.
Posted Aug 30, 2020 - 12:54 UTC
This incident affected: SSL.