Trust certificate orders
Incident Report for OpenSRS
Resolved
Our engineers have correct the issue with Trust orders and they should progress as expected at this time.


Incident start time: 2024-01-31 22:30 UTC
Incident end time: 2024-02-01 01:29 UTC
Total Duration:2hrs and 59 minutes
Posted Feb 01, 2024 - 01:52 UTC
Monitoring
Our Engineers have applied a correction to the Trust orders.

Customers should now be able to view the Trust page in their accounts without being logged out.

We are still monitoring the situation.
Posted Feb 01, 2024 - 00:42 UTC
Investigating
We are seeing an issue with Trust orders when placing, validating Trust orders.

Our engineers are aware of this issue and are currently investigating it.
Posted Jan 31, 2024 - 23:14 UTC
This incident affected: SSL.