OpenSRS Phone Support
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted 10 months ago. Oct 09, 2017 - 20:31 UTC
Monitoring
Inbound phone calls to OpenSRS Support has been restored. We will continue to monitor the issue until a full resolution is confirmed.
Posted 10 months ago. Oct 09, 2017 - 18:35 UTC
Investigating
Our phone system vendor is experiencing issues which may cause incoming calls to OpenSRS support to fail. We will update this status once there is more information.
Posted 10 months ago. Oct 09, 2017 - 15:56 UTC
This incident affected: Reseller Support.