Cluster B Webmail and Account Management
Incident Report for OpenSRS
Resolved
The issues we were experiencing on Cluster B have now been resolved.
Posted 2 months ago. Jul 12, 2017 - 15:02 UTC
Identified
Our operations team has identified an issue on Cluster B impacting webmail and account management. Users may experience slowness when using webmail and managing accounts in the Reseller Control Panel. We are working to resolve this issue as quickly as possible.
Posted 2 months ago. Jul 12, 2017 - 14:38 UTC
This incident affected: Hosted Email (Cluster B, Webmail).