Comcast/Xfinity Connections to HostedEmail
Incident Report for OpenSRS
Resolved
We are setting this issue to resolved on our end. For customers still affected, please contact Comcast/Xfinity for their latest service status.
Posted 5 months ago. Jun 29, 2018 - 21:12 UTC
Monitoring
-
As reported by major media outlets, Comcast/Xfinity is currently experiencing service issues. We will continue to monitor the situation but the issue does not appear to reside with HostedEmail at this time.
Posted 5 months ago. Jun 29, 2018 - 18:29 UTC
Investigating
-
Customers with internet service provided by Comcast/Xfinity might not be able to connect to our email service at the moment. We are investigating the issue and will provide more information when available.
Posted 5 months ago. Jun 29, 2018 - 17:54 UTC