Reseller Control Panel degraded performance

Incident Report for OpenSRS

Resolved

We were able to identify and resolve the issue impacting our Reseller Control Panel.
Posted Oct 15, 2025 - 15:00 UTC

Investigating

We are currently investigating an issue impacting the performance and operations of the Reseller Control Panel (manage.opensrs.com). Our team is currently working to provide a swift resolution as soon as possible
Posted Oct 15, 2025 - 14:48 UTC
This incident affected: Control Panels (Reseller Control Panel).