.Museum Registry Connection
Incident Report for OpenSRS
Resolved
Our connection to the .museum registry has been restored at 06:36 UTC.

Incident Start Time: 06-16-2021 04:06:00
Incident End Time: 06-16-2021 06:36:00
Total Duration: 2 hours and 30 minutes
Posted Jun 16, 2021 - 07:45 UTC
Update
We are continuing to investigate this issue.
Posted Jun 16, 2021 - 05:43 UTC
Investigating
We are currently experiencing connection issues with the .Museum registry. Our engineering team is investigating the issue.

This affects registrations, renewals, and management of .Museum domains. Existing domains will continue to resolve normally.
Posted Jun 16, 2021 - 04:28 UTC
This incident affected: Domain Services (Other gTLDs).