Cluster A Webmail Sending

Incident Report for OpenSRS

Resolved

Engineering has applied a fix and the issue has been resolved.
Posted Apr 22, 2026 - 20:45 UTC

Investigating

We are investigating an issue affecting outbound email sending on Cluster A, with failures observed in webmail showing SMTP connection errors. Our engineering team has been engaged and is investigating.
Posted Apr 22, 2026 - 20:41 UTC
This incident affected: Hosted Email (Webmail).