ccTLD connection latency

Incident Report for OpenSRS

Resolved

Our connections are now stable for ccTLDs.

This incident has been resolved.
Posted Apr 02, 2026 - 15:15 UTC

Investigating

We are currently experiencing delays when querying and submitting updates for certain ccTLDs like .DE, .FR and .MX.

Our engineering team is investigating this at this time. Existing domains will continue to resolve normally.
Posted Apr 02, 2026 - 13:28 UTC
This incident affected: Domain Services (Core ccTLDs, Other ccTLDs).