.UK Registry Maintenance
Incident Report for OpenSRS
Resolved
The scheduled maintenance has been completed.
Posted Feb 15, 2022 - 08:20 UTC
Identified
We've confirmed a Nominet registry maintenance is currently being performed. During this the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

All domains will continue to resolve. This applies to .blog, .cymru, .london, .rocks, .uk and .wales domains.
Posted Feb 15, 2022 - 06:55 UTC
This incident affected: Domain Services (Core ccTLDs).