Cluster B Email Login Issues

Incident Report for OpenSRS

Monitoring

A fix has been implemented and we are monitoring the results
Posted Apr 04, 2026 - 23:42 UTC

Update

The issue is still under investigation, and our team is actively working toward a resolution.
Posted Apr 04, 2026 - 23:14 UTC

Update

The issue is still under investigation, and our team is actively working toward a resolution.
Posted Apr 04, 2026 - 21:07 UTC

Investigating

The issue is still under investigation, and our team is actively working toward a resolution.
Posted Apr 04, 2026 - 19:26 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 04, 2026 - 18:20 UTC

Investigating

Please be aware we are currently experiencing issues with logging in to Cluster B email accounts via Webmail, IMAP and POP
Our engineers are aware and are working to resolve the issue. We will provide updates as they are available.
Posted Apr 04, 2026 - 16:49 UTC
This incident affects: Hosted Email (Cluster B).