.CA Renewal and Registration Errors

Incident Report for OpenSRS

Resolved

There was a certificate renewal at the registry which caused connection failures. CIRA reverted the certificate to restore these connections. This incident has been resolved.
Posted Aug 22, 2025 - 18:43 UTC

Update

Our engineers are in contact with the .CA registry and are working to resolve this matter. Further updates will be provided.
Posted Aug 22, 2025 - 16:41 UTC

Investigating

We are currently investigating an issue with errors received when attempting to register or renew a .CA TLD
After schedule Registry maintenance. Our engineers are working to resolve this as soon as possible and we will update you shortly.
Posted Aug 22, 2025 - 10:48 UTC
This incident affected: Domain Services (Core ccTLDs).