SystemDNS Record Deletion Issue

Incident Report for OpenSRS

Resolved

Our Engineers have resolved the issue with DNS records being removed when attempting to update the existing records.
Posted Feb 25, 2026 - 03:53 UTC

Identified

Our Engineers have identified the cause of this issue with DNS records being removed while updating existing records.

They are in the process of implementing a fix currently.

Updates to come as they are received.
Posted Feb 24, 2026 - 23:47 UTC

Investigating

We are currently investigating an issue involving DNS management in the OpenSRS control panel. Customers using the SystemDNS nameservers may see DNS records removed when attempting to update their records in the OpenSRS control panel. Engineering has been engaged and is investigating.
Posted Feb 24, 2026 - 21:59 UTC
This incident affected: DNS (SystemDNS).