Cluster B email delays
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted 12 days ago. Jul 06, 2019 - 16:20 UTC
Monitoring
Email serviced have been recovered on cluster B after operations implemented the fix, We will continue to monitor our services.
Posted 12 days ago. Jul 06, 2019 - 16:04 UTC
Identified
The issue has been identified and our operation team is currently working on a fix.
Posted 12 days ago. Jul 06, 2019 - 15:34 UTC
Investigating
We are currently investigating an issue with one of our email clusters.
Users on cluster B may experience inbound email delays during this time.

We will keep our clients informed on this matter as new updates become available.
Posted 12 days ago. Jul 06, 2019 - 15:03 UTC
This incident affected: Hosted Email (Cluster B).