Cluster B Sending Issue

Incident Report for OpenSRS

Resolved

This incident has been resolved.
Posted Jun 14, 2026 - 15:09 UTC

Monitoring

The engineering team identified an issue with our outbound mail filter that was impacting email sending. A fix has been applied and we are currently monitoring for recovery.
Posted Jun 14, 2026 - 14:28 UTC
This incident affected: Hosted Email (Cluster B).