.CA Registry Connection
Incident Report for OpenSRS
Resolved
Registry Services for the .ca TLD are back to normal.
Posted Sep 17, 2021 - 04:40 UTC
Update
We are aware of a connection issue to the .ca registry. We have reached out to the registry for an update.
Posted Sep 17, 2021 - 03:47 UTC
Investigating
We are experiencing connection issues to the .ca registry.

There will be issues with registering, managing and updating .ca domains.
Posted Sep 17, 2021 - 03:26 UTC
This incident affected: Domain Services (Core ccTLDs).