Cluster B delivery delays
Incident Report for OpenSRS
Resolved
Our Engineering team was able to identify the cause of the delays, a backlog relay queues and correct it, allowing the queues to process and deliver the messages.

Start Time: 04/20/2024 21:34 UTC
End Time: 04/21/2024 02:05 UTC
Duration: 4 hours, 31 minutes
Posted Apr 21, 2024 - 02:31 UTC
Investigating
We have reports that some customers on cluster B are having issue with mail delivery on cluster B.

Our engineering team has been engaged and is investigating the issue.

Start Time: 04/20/2024 21:34 UTC
Posted Apr 20, 2024 - 23:56 UTC
This incident affected: Hosted Email (Cluster B, Webmail).