System Status
Update - We continue to monitor and work towards a full restoration of the Webmail service, which is experiencing interruptions.

We appreciate your patience.

Further updates to come as they are received.

May 03, 2024 - 22:06 UTC
Update - Our team is still monitoring webmail as delays persist, all activity is expected to return to normal soon. Additional updates will be provided as they become available.

We appreciate your patience

May 03, 2024 - 14:31 UTC
Update - Our team continues to monitor webmail due to delays that remain ongoing.

We will provide further updates for you on this minor incident as they become available.

May 02, 2024 - 20:40 UTC
Monitoring - Our team has implemented a fix; IMAP and POP services are working again as expected.

We will continue to monitor the changes and webmail is expected to be back in full service shortly.

May 02, 2024 - 19:17 UTC
Update - We are continuing to work on a fix for this issue. We appreciate your patience.

The next update will be within one hour.

May 02, 2024 - 18:05 UTC
Update - We continue to work to restore full services. Webmail is currently experiencing interruptions due to an ongoing spam campaign.

Inbound email continues to be delivered to mailboxes without issue. Outbound email services may be degraded for some users.

Our next update will be within one hour.

May 02, 2024 - 17:04 UTC
Update - We are continuing to work on this major issue affecting email on Cluster A, including webmail, IMAP, and POP. Your patience is appreciated as we work towards a resolution for restoring full service.
The next update will be within one hour.

May 02, 2024 - 15:50 UTC
Update - At this time users may be unable to access email via IMAP, POP, or webmail.
We continue to work towards resolving the reported issues and will post another update once we have more information to share.

May 02, 2024 - 13:14 UTC
Update - We continue to work towards a resolution. We will have another update once new details are available.
May 02, 2024 - 12:32 UTC
Update - The issue with IMAP has been resolved. Our engineers are continuing to work on restoring webmail slowness and inability to log in.
We will provide another update shortly.

May 02, 2024 - 11:13 UTC
Identified - Our engineers have identified the problem and are working to bring Cluster A back up. We will update again shortly.
Thank you for your patience.

May 02, 2024 - 10:43 UTC
Investigating - We are currently experience a known issue impacting Hosted Email Cluster A
At this time you may not be able to log in via Webmail, IMAP, or POP3. Our engineers are aware of the situation and working to resolve it.
We will post updates as soon as more information is available.
Thank you for your patience.

May 02, 2024 - 09:11 UTC
Domain Services Operational
Core gTLDs ? Operational
Core ccTLDs ? Operational
Other gTLDs ? Operational
Other ccTLDs ? Operational
Premium Names ? Operational
WHOIS ? Operational
APIs Operational
OpenSRS API ? Operational
OpenHRS API Operational
Email API ? Operational
Hosted Email Degraded Performance
Cluster A Operational
Cluster B Operational
Webmail Degraded Performance
Control Panels Operational
Reseller Control Panel Operational
Classic RWI ? Operational
End User Control Panel Operational
Storefront Operational
Payment Gateway ? Operational
DNS Operational
SystemDNS Operational
Domain Forwarding Operational
SSL ? Operational
Reseller Support ? Operational
GoMobi Operational
System Messaging ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
Identity Digital Registry Maintenance May 6, 2024 22:00 - May 7, 2024 00:00 UTC
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Posted on Apr 19, 2024 - 22:43 UTC
.ORG Registry Maintenance May 7, 2024 17:00-19:00 UTC
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the PIR registry up in the following spreadsheet:
http://opensrs.help/chart

Posted on Apr 08, 2024 - 13:48 UTC
.SE Registry Maintenance May 15, 2024 19:00 - May 16, 2024 00:00 UTC
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Posted on Apr 19, 2024 - 23:02 UTC
.CH, .LI Registry Maintenance May 16, 2024 05:00-05:30 UTC
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Posted on Dec 19, 2023 - 20:36 UTC
.COM, .NET Registry Maintenance May 19, 2024 01:00-01:45 UTC
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Posted on Apr 19, 2024 - 22:48 UTC
.EU Registry Maintenance May 29, 2024 05:00-08:00 UTC
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Posted on Mar 05, 2024 - 16:18 UTC
.CH, .LI Registry Maintenance Jun 6, 2024 05:00-05:30 UTC
During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Posted on Dec 19, 2023 - 20:42 UTC
Past Incidents
May 4, 2024

No incidents reported today.

May 3, 2024
Resolved - Our engineering team has restored services, messages are being processed as expected.

We are very sorry for the disruption. Thank you for your patience.

Start Time: 05/03/24 10:00 UTC
End Time: 05/03/24 16:42 UTC
Total duration: 6 hours 42 minutes.

May 3, 17:18 UTC
Investigating - We are experiencing delays on the registrar mail system used to relay registrant verification and other system messages. Our engineering team has been engaged and are actively working to resolve the issues.
May 3, 16:28 UTC
May 2, 2024
May 1, 2024
Resolved - The service has been completely restored. If you are still experiencing issues, please don't hesitate to contact us!

Start Time: 05/01/2024 16:56 UTC
End Time: 05/01/2024 17:46 UTC
Total duration: 50 minutes

May 1, 18:28 UTC
Investigating - We are investigating an issue affecting some users on Cluster A accessing webmail. IMAP and POP services are unaffected. Our engineering team has been engaged.

We will provide an update once we have additional information.

May 1, 17:12 UTC
Resolved - This incident has been resolved.
May 1, 01:12 UTC
Update - Our engineers have resolved the Registrar Mail delays at this time.

Domain related emails are now being delivered as expected.

Start Time: 13:11 UTC 04/30/2024
End time: 20:51 UTC 04/30/2024
Duration: 7hours 40 minutes

May 1, 01:12 UTC
Update - We are still experiencing delays on verification emails. We will provide further updates on our status page as soon as new information becomes available.

Thank you for your patience and understanding.

Apr 30, 20:30 UTC
Investigating - We are experiencing delays on the registrar mail system used to relay registrant verification. Our engineering team has been engaged and are actively working to resolve this issue.
Apr 30, 18:43 UTC
Apr 30, 2024
Completed - The scheduled maintenance has been completed.
Apr 30, 11:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 30, 08:00 UTC
Scheduled - During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Apr 25, 15:49 UTC
Apr 29, 2024
Resolved - The incident involving Hosted Email Cluster A has been resolved. Engineering implemented a fix and service levels have been restored.

Start Time: 04/29/2024 11:21 am UTC
End Time: 04/29/2024 15:28 am UTC
Length: 4 hours 7 minutes

Apr 29, 15:55 UTC
Investigating - We are encountering intermittent issues with Cluster A Webmail. Customers will intermittently be unable to login to or access webmail in Cluster A.

We will provide an update once we have additional information.

Apr 29, 12:56 UTC
Apr 28, 2024

No incidents reported.

Apr 27, 2024

No incidents reported.

Apr 26, 2024
Resolved - Our Engineers were able to find the cause of the slowness in Cluster A webmail and rectify it.

Service is once again working as expected.

Start Time: 04/25/2024 14:12 UTC
End Time: 01/25/2024 21:14
Duration: 7 hours, 2 minutes

Apr 26, 01:54 UTC
Update - Update -- The investigation continues for the Cluster A webmail slow and unresponsiveness.

Further updates to come.

Apr 25, 21:55 UTC
Update - We are still investigating this issue. We will provide further updates on our status page as soon as new information becomes available.

Thank you for your patience and understanding.

Apr 25, 19:04 UTC
Investigating - We're currently experiencing issues with webmail on Cluster A being slow/unresponsive, also impacting login.

We are investigating this issue and will post updates as they become available.

Apr 25, 16:01 UTC
Apr 25, 2024
Completed - The scheduled maintenance has been completed.
Apr 25, 05:30 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 25, 05:00 UTC
Scheduled - During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Dec 19, 20:35 UTC
Completed - The scheduled maintenance has been completed.
Apr 25, 00:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 24, 19:00 UTC
Scheduled - During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Apr 19, 23:01 UTC
Apr 24, 2024
Apr 23, 2024
Completed - The scheduled maintenance has been completed.
Apr 23, 22:30 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 23, 22:05 UTC
Scheduled - During this scheduled system maintenance by the registry, the following services may be unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Apr 19, 22:54 UTC
Completed - The scheduled maintenance has been completed.
Apr 23, 14:30 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 23, 14:00 UTC
Scheduled - During this scheduled system maintenance by the registry, the following services may be intermittently unavailable:

Availability Checks
Whois Services
Domain Purchases
Domain Renewals
Domain Updates

For a list of affected TLD's, please look the registry up in the following spreadsheet:
http://opensrs.help/chart

Apr 16, 18:28 UTC
Apr 22, 2024

No incidents reported.

Apr 21, 2024
Resolved - Our Engineering team was able to identify the cause of the delays, a backlog relay queues and correct it, allowing the queues to process and deliver the messages.

Start Time: 04/20/2024 21:34 UTC
End Time: 04/21/2024 02:05 UTC
Duration: 4 hours, 31 minutes

Apr 21, 02:31 UTC
Investigating - We have reports that some customers on cluster B are having issue with mail delivery on cluster B.

Our engineering team has been engaged and is investigating the issue.

Start Time: 04/20/2024 21:34 UTC

Apr 20, 23:56 UTC
Completed - The scheduled maintenance has been completed.
Apr 21, 02:16 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 21, 00:16 UTC
Scheduled - Sectigo is undergoing scheduled maintenance. This may affect all Sectigo products and services.

Affected services:
Sectigo Portal
Sectigo API
Order placement
Order Reissuing

This maintenance is expected to last 2 hours after which regular service will resume

Apr 21, 00:15 UTC
Apr 20, 2024